ftp hang. Connection closed by remote host.

Discussion in 'Plesk 7.0 Troubleshooting and Problems' started by aboyz, Feb 28, 2004.

  1. aboyz

    aboyz Guest

    Hi,

    I'm having trouble ftp into my box. sometime it work and doesn't it give me. Connection closed by remote host. what is the problem? anyone know why? sometime it let me ftp in , but it will take like 1min or so. That is way tooo long.. i did a port scan on the box and ftp is open. But what is causing the hang? anyone got any reason that i can look that up.

    thanks
     
  2. defencer

    defencer Tera Poster

    Messages:
    408
    Is there any problem messages in /var/log/messages ?
     
  3. aboyz

    aboyz Guest

    its slow. wonder what is the cause of this?

    My ftp is slow. When i try to ftp into the box. its so slow, i gotta wait like almost 1min before it show login screen. this is sad.. What is the casuing of the hang on proftpd? anyone got any ideas? or diagnose technique to solve this?

    NOPE nothing in /var/logs/message
     
  4. defencer

    defencer Tera Poster

    Messages:
    408
    I have at least "FTP session opened/closed" in messages file.

    May be your FTP server tries to make backresolving ? Try to connect to your FTP server locally, i.e. from the plesk host.
     
  5. aboyz

    aboyz Guest

    what plesk host?

    you mean try to connect in where?

    I don't get it.

    You want me to try to ftp localhost

    like that??
     
  6. defencer

    defencer Tera Poster

    Messages:
    408
    Access the host where plesk installed via ssh, and yes, try "ftp localhost" and see if it be the same long.
     
  7. aboyz

    aboyz Guest

    yes it does.

    yes it does :( wired..

    I tried another plesk server with ftp localhost and its super fast..

    why does it hang??

    please advise.. thanks

    it hang even when i did a ftp localhost

    what is the cause of this. running freebsd 4.9 with plesk 7
     
  8. defencer

    defencer Tera Poster

    Messages:
    408
    hmm...

    Well, try to remove /usr/local/psa/ftpd/var/scoreboard file. If it not help, try to start proftpd as a standalone server, i.e. not through inetd. Also you can see the /usr/local/psa/proftpd/etc/proftpd.conf and /usr/local/psa/proftpd/etc/proftpd.include files. May be you will find something strange there.
     
  9. aboyz

    aboyz Guest

    not doing it.

    Arg,

    this is not a proftpd issues. I think its some /etc/hosts issues. as it is lagging on localhost

    or hanging.. It seem like its checking something before it can let it log in. I waited about like 1mins before it start to prompt me for a login .

    I have seen this problem before, but forgot how to fix it..

    anyone know what i can try..
     
  10. EnigmaX

    EnigmaX Tera Poster

    Messages:
    381
    Might be a long shot..

    I had a similar issue when the firewall was
    set a too strict on the in/out traffic and had
    some minor issues with lookups.

    I read a post here and suggested to add the
    following in your proftpd.conf file..

    Turn DNS lookups off on the FTP server to see
    if it is a DNS issue.

    Add the following line:
    UseReverseDNS Off

    But like prev. post you tried a localhost login
    and still no result. But for the rest this trick
    really speeded up the connection/login.
     
  11. aboyz

    aboyz Guest

    Thansk

    Thanks for the reply, but today, I did a check on it and everything is smooth . Really don't know what the problem is. :) Everything seem sooo smooth now..

    thanks all...
     

Share This Page