Apache regular down

Discussion in 'Plesk 7.0 Troubleshooting and Problems' started by webizz, Jul 4, 2004.

  1. webizz

    webizz Guest

    Hi all,

    We are experiencing problems with a couple of FreeBSD 4.9 servers with Plesk 7.0.3 installed. Apache (only apache, the plesk admin and other services are not effected) frequently crashes without any obvious reason.

    The apache error log states:

    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    critical_acquire() failed: Invalid argument
    critical_release() failed: Invalid argument
    [Sun Jul 4 21:16:09 2004] [warn] pid file /usr/local/psa/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Sun Jul 4 21:16:10 2004] [notice] Apache/1.3.31 (Unix) mod_python/2.7.10 Python/2.2.2 mod_webapp/1.2.0-dev mod_perl/1.29 mod_throttle/3.1.2 PHP/4.3.4 FrontPage/5.0.2.2510 mod_ssl/2.8.18 OpenSSL/0.9.7d configured -- resuming normal operations
    [Sun Jul 4 21:16:10 2004] [notice] suEXEC mechanism enabled (wrapper: /usr/local/psa/apache/bin/suexec)
    [Sun Jul 4 21:16:10 2004] [notice] Accept mutex: flock (Default: flock)

    Almost 98% of the error logfile consists out of the critical_acquire and the critica_release line.

    Anyone any idea what this could me and how we can solve the problem? Thanks in advance.
     
  2. ccwebhost

    ccwebhost Guest

    I am having the same problem on two different servers except I can't find any errors in any logs and its with Plesk 6.

    Apache stops responding and only a reboot will get it going again. Restarting apache doesn't generate any errors and appears to start fine but it doesn't respond.

    It occurs randomly, or I just haven't hit the right combination to track down what causes it. I'm looking into possible memory problems somewhere but its hard to diagnosis problems on production servers when your customers are complaining their web server is down.
     
  3. webizz

    webizz Guest

    We have had the problem you describe above also once and fixed it with adding some lines to the kernel configuration file:

    options IPFIREWALL
    options IPFIREWALL_VERBOSE
    options IPFIREWALL_FORWARD
    options IPFIREWALL_VERBOSE_LIMIT=100
    options IPFIREWALL_DEFAULT_TO_ACCEPT
    options IPDIVERT
    options SHMMAXPGS=4096
    options SHMSEG=256
    options SEMMSL=1536
    options SEMMNI=256
    options SEMMNS=512
    options SEMMNU=512
    options SEMMAP=512
    options SEMOPM=2560
    options SEMUME=256
    options NMBUFS=53248
    options NMBCLUSTERS=13312
    options ACCEPT_FILTER_HTTP

    This solved the problem with shared memory leaks. Unfortunately we still experience the problems mentioned in the first post.
     
  4. Blaster

    Blaster Guest

    I have the same problem, as to make?
     
  5. Blaster

    Blaster Guest

    I solved the problem.

    I have to modify the Apache configuration /etc/httpd/conf/httpd.conf

    Find:

    MaxClients 300 ( or 150 ? )

    Replace by:

    MaxClients 30

    And restart server .
    /sbin/reboot

    Later ca I have nobody more concerns with Apache for the moment.
     
  6. webizz

    webizz Guest

    It looks like we solved the problem also. We removed the '--nostop' tag from the backupcommand and all servers are working fine now...
     
  7. Blaster

    Blaster Guest

    I by applying the modif in mysqld ca has to work during 1:30 am and ca begin again...
    By modifying the configuration max_client, work for 4 days :D
     

Share This Page